The maintenance was completed at 2025-10-12 14:45:20 CEST and started at 2025-10-12 14:32:00 CEST.
Posted Oct 12, 2025 - 13:09 UTC
Update
This will begin at around 14:30 CEST.
Posted Oct 12, 2025 - 12:19 UTC
Scheduled
We will perform scheduled maintenance to increase capacity.
The maintenance is expected to take around 10-30 minutes each.
The time frame will be updated to a more specific time once coordinated with local DC technicians. We will give updates should the maintenance start later due to unforeseen circumstances or similar. If you believe to be affected by this, you are welcome to contact support for further information on implementation of redundancy.
There will be no impact to Remote Shield customers and only an intermittent disconnect for Game Shield players during this maintenance window that is done during low traffic times locally.
One maintenance will be done at a time, redundant tunnels will eliminate any risk of downtime. Game Shield will failover automatically and may only experience intermittent session disconnections at the affected PoP.
Reach out to support in case of any questions, thank you for your understanding.