Degraded performance of the U.S. network due to sophisticated attacks

Incident Report for NeoProtect

Resolved

This incident is set resolved. A post-mortem will follow here or individually via support.
Posted Oct 08, 2025 - 20:06 UTC

Update

We have deployed further optimizations across the board to minimize impact over the last few hours gradually.

Depending on the end-location, you may still see certain impact. We apologize for the expedited timeline of this situation.
Rest assured we are doing everything in our power to get this under control.

We will, alongside the already scheduled and planned updates for this weekend in Chicago and Miami that will increase capacity each, upgrade capacity further in LAX, DAL, MIA and CHI. This is around another 1T of additional capacity, the ETA for receiving of the latter is at max. Tuesday (7th) of what we received from our upstream.

Just to note here again: EU customers are generally unaffected.

Thank you for your continued support and patience while we work through such difficult times.
Posted Oct 04, 2025 - 00:03 UTC

Investigating

We have faced several 60-second attacks in the last few hours, resulting in frequent network issues around the affected network locations.

Our team is actively working to reduce the impact with all tools being used and altered as we go forward.
This is one of the most advanced attacks we have seen to date, targeting ~100k IPs simultaneously with bots mainly originating from the U.S. . The total size of the attack is multiple Terabits, but we are unable to confirm the total size at this time.

We will keep you updated on this case here, reach out to our support if you believe to have valuable information in regards to the impact scope or similar.
Thank you for your continued support and patience while we work hard to resolve this.
Posted Oct 02, 2025 - 21:29 UTC
This incident affected: Network Edge Locations (MIA - Miami Edge Network, CHI - Chicago Edge Network, DAL - Dallas Edge Network, LAX - Los Angeles Edge Network, SEA - Seattle Edge Network).