Game Shield (FRA): Increased connection degration on our OVH Limburg location

Incident Report for NeoProtect

Resolved

This incident is resolved. We will keep balancing traffic by default across multiple providers for the time being.
The last recorded degration was at 2026-04-25 21:11:35 CEST.

Thank you for your understanding.
Posted Apr 25, 2026 - 22:30 UTC

Investigating

We are seeing increased connection degration on our OVH Limburg location since 2026-04-25 19:40:40 CEST that seems to affect various destinations.
This does not seem to be caused by an attack but issues within OVH's network.

We are re-routing traffic to alternate providers and you may thus update your whitelists accordingly.

Thank you for your understanding and patience.
We will update here once we have more information or progressed further in resolving the issue at hand.
Posted Apr 25, 2026 - 18:44 UTC
This incident affected: Network Edge Locations (FRA - Frankfurt Edge Network).