Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 11, 2025 - 01:30 UTC
Scheduled
We are deploying general improvements for our Game Shield to improve loading times for the MOTD cache, along with smoother connection experiences globally and improved logging.
Due to an additional update concerning the handling of new flows on edge nodes for Game Shield, any edge node that was not part of maintenance in the past few weeks has to undergo a "disruptive" update that will have a single intermittent disconnect of online players as a consequence. The timeline of this maintenance serves solely as a placeholder and does not represent impact/actual duration of the updates.
We will perform these disruptive updates each at ~4:00 am local time, which is the point in time that has the lowest legitimate traffic levels each day. Starting with EU tonight at 4:00 am, most of the U.S. being done already but remaining locations being done at ~11-12am CEST tomorrow.
Thank you for your understanding while we work to improve our service. Contact support should you experience any issues.
Posted Oct 10, 2025 - 22:17 UTC
This scheduled maintenance affected: Services / Products (Game Shield Service).